Windows 10 - Sound / Communications setting - "When windows detects communications activities" not working for Zoiper

0 votes

Hi,

I am running Windows 10 on my desktop. I have speakers (via audio jack) and a headset (USB) connected. I listen to the radio via the browser and speakers a lot. When I receive a call via Zoiper, I currently have to find the right browser tab, mute the radio, click on the "Speakers / Headphones" icon on the desktop, swap the playback device from speakers to headset, pick the headset up, put it on and then click on Zoiper to answer the call.

Via my provider I currently have the ring duration set to 20 seconds (it then diverts to my mobile). I am failing to do all of the above before the divert kicks in. I would prefer to answer on the PC (to save divert call costs), but want to keep the divert in place with the 20 seconds (so when it diverts it is not excessive before voicemail comes in). I thought there had to be a better way and found a Windows Sound setting (on the communications tab):

You can see the dialog box here

"A handy function of the Windows sound settings is the ability to modify audio behaviour when multi-tasking. ...If you use an application such as Skype to send and receive video calls, Windows can be set to adjust the volume automatically when communication activity is detected."

With the ability to mute the speakers this all looks / sounds like it will do just what I want but a test has shown it doesn't work with Zoiper. Any ideas please? 

Thanks,

James


asked Feb 8, 2017 in Windows by JamesF (120 points)  
share

1 Answer

0 votes

Go to windows audio settings and make the USB headset the default communications device and your speakers the default device.  Yes, you can do this!

Then to go Zoiper and make sure under settings, audio, device, only the first two options say USB Headset.

This will accomplish what you want.

answered Feb 10, 2017 by rafavargas (740 points)  
share

Thanks for your response. I hadn't seen the device settings. This is definitely progress, thanks very much. When I answer it now goes straight to headset without any manual intervention. The music (in a browser window) is not muting. I did read that the windows audio settings muting might not work with music in the browser. I can just switch off the speakers (switch on them - quicker than finding the right windows and clicking!).

Welcome!
Ask your questions and receive answers from other members of the Zoiper Community.

Did you check our Help Section?

You are a Zoiper Biz or Premium customer? If so, click HERE to get premium support.
Top users 01/2019
  1. Tsetso.Zdravkov

    23600 Points

  2. Ivan

    18370 Points

  3. Joachim

    11490 Points

  4. Anton

    3950 Points

Latest tweets