I am using Ubuntu 16.04 Zoiper5 desktop and I have one way sound (just outgoing sound , but not incoming sound)

0 votes

Good morning/afternoon/evening.

Short description: I want to use Zoiper softphone on my desktop computer to make outgoing calls (That's it).

Detailed description:

I have a SIP currently working account, for example: ( user: 1234, domain: mydomain.co ,pass: qwerty123456) . I am able to make calls using zoIPer android app (USING a data package through 3G/4G network on my celphone with Android5 OS) and everything works fine. But, when I try to use Zoiper through WiFi or LAN(No matter if it is with the same celhpone or with my laptop) ( that is, connected to internet via modem/Router CISCO DPC3825 or if I use the celphone as wiFi hotspot) the call connection is stablised, but there is not incoming audio ( I mean, If I call you, you would be able to hear my voice (outgoing packages ) but I will NOT be able to hear you (zero incoming packages)).

Note0: During the call I opened up the option that says "statistics " and it shows just outgoing packages but Zero (not) incoming (received) packages.

Note1: I had been looking information about "zoIPer ONE WAY AUDIO" and I had found that when I am connected to a modem I need to check:

* If the modem blocks SIP using ALG- onSIP.  ( I was checking the modem/router CISCO DPC3825 manual and also I logged in into that modem/router and I was not able to find that option available (it seems it does not exist)).

* If the modem/router firewall is blocking ZoIPer ports ( in the modem, I disabled firewall for IPV4 ,IPV6 and there is a message tha says " No ports restricted").

* If there is port forwarding incorrectly done (in the modem, port filtering is disable, not port forwarding enabled, not port triggering enabled).

* Check if it is possible to setup VPN passthrough or set up your VPN to overpass NAT ( I dont know how to do it).

I already checked previous advises and it seems, so far, none works for me or, I did not followed them properly.

Note 2: At this point I really do not know what else shoud I check. I already checked the CODECs used and noticed (when using 3g/4G networkd the GSM codec works perfect but not when using WiFi). To address the NAT communication I activated the option STUN server on zoIPer (desktop and android app) but still the same issue ( call connections are stablished , people is able to hear my voice, but I am unable to hear them).

Note 3: I don't know if I need to set up my modem/router in such a way that it may not interfere with ZoIPer softphone and how to do it.

Thank you very much in advance for all your help.!!!

Note 4: This is my laptop description:

Reference: Asus R401VM (Laptop)

OS: Linux Ubuntu 16.04 (64 bits)

Zoiper used: I downloaded and installed Zoiper5, free version, and installed the .deb package (Note I already check that all libraries and dependencies where satisfied).

 

asked Feb 15 in Linux by ich (120 points)  
share

I've found something about how to disable the SIP ALG on CISCO with IOS, here:

http://www.surevoip.co.uk/support/wiki/troubleshooting:sip_alg:cisco_ios

This seems to disable the ALG for port 5060, but you should also use it for port 8000 (this is where the RTP or the audio stream is going).


However when you enable this, since this will affect only the routing on port 5060, you need to also disable the "Open random port above 32000" in Zoiper. 

Disabling or enabling STUN and Rport may also help. As a final option you can try to use TLS + SRTP if your PBX is supporting those for transport.  


Please log in or register to answer this question.

Welcome!
Ask your questions and receive answers from other members of the Zoiper Community.

Did you check our Help Section?

You are a Zoiper Biz or Premium customer? If so, click HERE to get premium support.
Top users 09/2018
  1. Tsetso.Zdravkov

    22340 Points

  2. Ivan

    18370 Points

  3. Joachim

    11480 Points

  4. Anton

    3950 Points

Latest tweets