Registration fail when changing network with Push Notification

+1 vote


I'm using the ZoiperBeta 2.6.26 to see if Push Notification work great In fact, it work but when i change wifi network, ZoiperBeta is not able to reconnect by itself (or not always). I must close the app and reopen to make it work properly.

Is it a known bug or I'm doing something wrong?

asked Sep 18, 2018 in Android by skoub (240 points)  
reshown Dec 12, 2019 by skoub

I am getting this on my Zoiper for Android v2.9.19

On Huawei CLT-L29 (P20 Pro)

I wonder what has happened recently to make it start again?

I have checked the power yes. 

Appears to be working recently... Go figure. 

2 Answers

0 votes
Best answer


We have prepared a fix for this which will be release with our next Zoiper update.

answered Sep 18, 2018 by Tsetso.Zdravkov (34,210 points)  
selected Sep 19, 2018 by skoub

I Switched to paid service to benefit from push but also getting  Bad request - Missing push device token (400). I trust my issue is related to this thread? When is the next release cause Im already being billed for this service

have been being zoiper fans, but............but almost not working on both iphone and android after upgrading.  Wish  the bug could be fixed soon.

Email notice would be appreciated if you have solved this problem.


I believe this issue should have been solved with Zoiper 2.6.39 for Android.

In some rare cases however, you could still encounter it. For example you have a private DNS name for your PBX, pointing to internal IP address.

0 votes

I found changing connectivity from mobile to wifi and back often gave me the same error. 400, push token error.

After playing with firewalls and all the network settings a lot, I found disabling the PUSH functionality immediately gave me a correct connection!  But it warns correctly that you would not receive calls that way. The error is in this function, which I purchased for lowest energy consumption.

So, it wasn't firewalls or anything, there is an error in this push module in the background...
At least I have connectivity again, but far removed from ideal... 

Then I tried the recommendation for Huawei phone, and entered App Info, Battery usage, Optimizing battery usage, allow to be managed ON, and then get it OFF the managed list again. It was unmanaged, but I added it specifically to the list, and took it off again...

It was without PUSH when I did this. (checkmark in notification area, ZoiPer running without push enabled.)
I activated push again, the ZoiPer service was restarted, Checkmark disappears during...
And then it CAME BACK! Yesss!! This seems to work!

I run this on a Samsung Note 8, latest update...

answered Mar 4, 2020 by fnaaijkens (140 points)  

Hi, you might see the missing token error, when your phone was lacking public network connection or there was an issue with the Google Play services which lead to the phone being unable to receive the PUSH token from the Google servers. A simple restart of your phone should generally fix this or disabling/ enabling the airplane mode to reset the network connectivity.

Ask your questions and receive answers from other members of the Zoiper Community.

Did you check our Help Section?

You are a Zoiper Biz or Premium customer? If so, click HERE to get premium support.
Top users 09/2021
  1. Tsetso.Zdravkov

    34210 Points

  2. Ivan

    18410 Points

  3. Joachim

    11490 Points

  4. Anton

    3950 Points

Latest tweets