Problem with incoming call on 3g

0 votes

Hi,

If i'm on wifi everything works fine. If i'm on 3g only the outgoing calls work. He says Cloud pbx is ready.

Can someone point me in the right direction?

Thanks a lot

Regards,

Jonas

asked Dec 4, 2015 in Android by Complit (160 points)  
share

Hello,

to be able to receive incoming calls your account needs to be registered with the server all the time. Could you please let us know if the issue appears only when the phone is on standby (screen is locked) , or also when Zoiper is open on the screen?

Are you using a SIP account?

If so, please try using TCP transport as UDP is not reliable;

1 Answer

0 votes

Hi,

It's also if the zoiper app is open.

Yes I'm using a sip account.

If I change to TCP or TLS I get an error "Registration failed (Transport failure: no transports left to try...

I have purchased Zoiper Gold.

Regards,

Jonas Dekkers

answered Dec 7, 2015 by Complit (160 points)  
share

Hello,

Most probably your provider supports only UDP transport. Lack of incoming calls indicates a NAT related issue, so please try altering STUN and rport options. You can also try using custom STUN server instead of the default one.

I have tried to change the stun an rport options. Without any succes.

Can you give me more information about the custom stun servers?

stun.l.google.com:19302 this is google stun server. 19302 is the port. I doubt stun will help, there is probably some filtering on the firewalls from your Mobile data provider. Try also to disable "random listening port" for SIP in "Connectivity"-"listening ports".

Welcome!
Ask your questions and receive answers from other members of the Zoiper Community.

Did you check our Help Section?

You are a Zoiper Biz or Premium customer? If so, click HERE to get premium support.
Top users 02/2020
  1. Tsetso.Zdravkov

    28660 Points

  2. Ivan

    18410 Points

  3. Joachim

    11490 Points

  4. Anton

    3950 Points

Latest tweets