ANDROID - Zoiper fails to re-connect after network loss

+2 votes

Android M 6.0.1.

Zoiper always fails to re-register after a network connection was dropped.

I switched off Wifi (to simulate leaving the house) and back on after about 5 min.

Zoiper is never able to re-establish a connection to the server, until I run the app manually.

Sipdroid for example, re-connects within a few seconds, after the network connection is available again.

I definitely prefer Zoiper over Sipdroid, but with this behaviour, Zoiper is just unusable for me.

asked Jan 5, 2016 in Android by Scoo Ter (190 points)  
share

I have the same problem. After a Network loss zoiper tries to register my account again. After about two minutes I get "DNSTimeout (503)" I have to go to connections and just click save then it works again.

My phone is a Motorola Moto G 3 (2015) with Android 6,

I could also provide logs if this helps.

2 Answers

0 votes
Best answer

please upgrade to version 1.36

(1.35 still had a problem with some stun related setups)

answered Apr 27, 2016 by Joachim (11,490 points)  
share

I have a similar problem, it is not fixed with version 1.36...

I already sent debug logs to the support some weeks ago, is there anything else I can do to help resolving this issue? 

Please send us new debug logs on support@zoiper.com and mention you are running 1.36.
It is most likely a different problem as so far the feedback on the bugfix seems positive.

Is this android 6.0 ?

Yes, it's a Nexus with Android 6.0.1.

I've enabled debug mode and will try to reproduce the issue. 

android 6 has some new battery saving features, you will need to place zoiper on the exception list.

This seems to be a very valuable hint, on the first glance the connection problems are solved after putting zoiper on the exception list. 

Suggestion: when zoiper is started on an Android 6.x device, show a popup with this information, unless zoiper is already on the exception list - together with a short explanation how to change it. 

I can confirm, 1.36 did not fix the problem

I had an Internet outage yesterday (1 hour) and after that was fixed, Zoiper tried to re-register forever.

I had to kill the app via settings to get it working again.

"android 6 has some new battery saving features, you will need to place zoiper on the exception list. "

I will try that...

I still see reconnection problems (using 1.36), but they seem to be less than before putting zoiper on the battery saving exception list.

I've two accounts, a sipgate.de and an iptel.org account, the reconnection problems seem to occur only with the sipgate.de account. Maybe other users can confirm this?

Just sent the debug logs from the app.

Any news here? 

I still have reconnection problems with zoiper... In the meantime I (temporarily) switched to CSipSimple, which works like a charm. So it's not related to Android nor to my VOIP provider. 

0 votes

Hello,


What model of phone is this ?

Can you try using the ip address of the server instead of the hostname ? We have seen some problems related to the dns cache in Android.

Can you contact the zoiper team so that they can get your log files to investigate this further ? (support AT zoiper.com, mention the community post please)







answered Jan 5, 2016 by Joachim (11,490 points)  
edited Jan 5, 2016 by Joachim
share

Any news since February? I had same problem (so stable version has not been updated yet?). Just installed the beta version (cannot tell yet wether the problem is fixed here), which sais that it will expire in the future. So how will this go on?

Based on the feedback we got, the issue has been fixed for 99% of the people.
We still got some reports from a handful of people but have not received logfiles to confirm the issue or troubleshoot it. (It could be the provider rejects the registration because of too many registration attempts as well).
The changes we made are in the current stable, no need to test the beta.

If you are still having issues on network change, we beg you to please contact support@zoiper.com, tell them you experience registration issues on network change and follow their instructions and send us the debug logs so that we can look into this.


Thank you !!!

Zoiper 1.40

Still not fixed...

We found the issue, it has been fixed in 1.41 (in staged rollout to 20%) and the current zoiper beta.

Unfortunately we found a big problem in 1.41 (and 1.42) that we are trying to fix. Give it a couple of days and 1.43 will be out hopefully.

1.43 seems to have fixed it eventually...

Welcome!
Ask your questions and receive answers from other members of the Zoiper Community.

Did you check our Help Section?

You are a Zoiper Biz or Premium customer? If so, click HERE to get premium support.
Top users 09/2020
  1. Tsetso.Zdravkov

    33510 Points

  2. Ivan

    18410 Points

  3. Joachim

    11490 Points

  4. Anton

    3950 Points

Latest tweets