Very low TX audio on Android

0 votes

Hi,


I'm using Zoiper 1.23 on Android. No matter the settings I use for making a call, the outbound (Receiving) audio is very low. The other end describes it as 'sounds like you're in a tunnel'


I have tried every setup and configuratoin possible including,  using SIP, changing to IAX, going through my PBX, or just registering directly to the provider (Voip.ms). I have tried toggling automatic gain control, to no affect. When I am internal, directly connected via IAX to the PBX internal IP, and do an echo test, I have confirmed the audio is unacceptably quiet. I have tested this again, outside the network, using sip connection, and then tested the echo test at Voip.MS, to the same effect. On every channel, trunk, protocol, and network, this issue is repeatable. THE TX AUDIO IS TOO LOW. 


Where can I change TX Gain in zoiper; or better yet, can you guys fix the audio transmission volume level please. 

asked Jul 26, 2015 in Android by Chris Williams (130 points)  
share

2 Answers

0 votes

The auto gain control should automatically adjust the volume to be exactly as is expected by the PSTN. You should not be adjusting the gain levels manually as it can lead to distortions.

What phone model is this on ?

Are you able to make a packet capture, including RTP with auto gain enabled that you can send us ? 


answered Jul 26, 2015 by Joachim (11,490 points)  
share

pcap is with AGC enabled. 

Please try with the stock firmware if you can, the cyanogen firmware is known to have serious audio problems because they change the buffer sizes.

Hello I just found this thread as I have the same problem with my new Galaxy S3 Mini (GT-I8200N) with the default firmware when using Zoiper 1.23 the TX audio is really low. When I make a GSM call or use the audio recorder I have the feeling that the AGC is fixing the problem but in Zoiper the TX audio remains low. Is there any way I can enable AGC in Zoiper?

Okay, I tested with stock android 4.4


The audio through Zoiper on the stock android was louder than CyanogenMod, but was still quieter by far, than a normal phone conversation would be. This was with ACG enabled. 


However, due to this information I think it is a CyanogeMod issue, and not a Zoiper issue. 

I'm experiencing the same issue, low mic volume. I'm using version 1.27 on Xiaomi 4c, with MIUI 7 (Android 5.1.1). 


Any recommended fix?

0 votes

I finally found a fix for my LineageOS 14 (basically the new name of CyanogenMod), so I decided to leave an answer here for future readers.

Using a build.prop editor (from the Play Store) I changed:

use.dedicated.device.for.voip=true

To:

use.dedicated.device.for.voip=false

This solution is also suggested here: https://forum.xda-developers.com/lg-g3/help/fix-fix-voip-calling-lollipop-roms-t2980294

You need to reboot the device after applying the fix.

answered Dec 6, 2017 by Lazza (140 points)  
share
Welcome!
Ask your questions and receive answers from other members of the Zoiper Community.

Did you check our Help Section?

You are a Zoiper Biz or Premium customer? If so, click HERE to get premium support.
Top users 08/2019
  1. Tsetso.Zdravkov

    26240 Points

  2. Ivan

    18370 Points

  3. Joachim

    11490 Points

  4. Anton

    3950 Points

Latest tweets