Cant hear caller when connects

0 votes


For the past few months, whenever I make a call using Zoiper, the call will dial but when it connects, I hear nothing. The call has connected because I can see that the call timer has commenced. It does the same thing whether I use Localphone or another telephone provider, so I think it is the Zoiper client.

Can you advise if this is a setting wrong or what the problem might be?

My phone is Android (HTC Desire 510) with Zoiper.


asked Jan 14, 2016 in Android by tannaroo (170 points)  
share

2 Answers

0 votes

If you are using SIP account, please try to enable or disable STUN in account configuration -> "Network Settings".

Do you use TCP or UDP? Please try using TCP if your provider supports it.
You might want to try changing the audio driver in Zoiper -> Config -> Audio settings.

answered Jan 14, 2016 by Katina (23,910 points)  
share

Thanks for that. The STUN was not enabled, so I enable but now the SIP says "not registered". So I cannot use it. So I think I have to switch off the STUN.


I could not find TCP or UDP through Zoiper -> Config -> Audio


Any other suggestions?

To change the transport type for your account you need to run Zoiper for Android, go to Config, then go to Accounts, select your account and scroll down to Network Settings. Change the transport type to UDP, TLS or TCP, according to your provider's recommendation.

Ok thanks. I did try to change to TCP but when I can back into network settings its reverts back to UDP, so looks like that is my only option.


So I am back to square 1.

Hello,

can you please share which is the exact version of zoiper that you are using?

Zoiper 1.30 for Android.


Is that the current version?

0 votes

Hey there! What you are experiencing is a NAT related issue:

- check the Statistics menu while in a call. If incoming packets = 0 then something is blocking audio from remote party

Try to alter STUN and rport. Try different combinations and make some test calls.

Another thing is to make sure firewall device is not blocking/rewriting ports. Default ports are:

SIP port is 5060
IAX port is 4569 UDP
RTP port is between 32000 and 65535 UDP

Default STUN vallues:
Server hostname /IP :stun.zoiper.com
Port :3478 UDP / TCP
Refresh period : 30

answered Jan 20, 2016 by Anton (3,950 points)  
share
Welcome!
Ask your questions and receive answers from other members of the Zoiper Community.

Did you check our Help Section?

You are a Zoiper Biz or Premium customer? If so, click HERE to get premium support.
Top users 06/2020
  1. Tsetso.Zdravkov

    32670 Points

  2. Ivan

    18410 Points

  3. Joachim

    11490 Points

  4. Anton

    3950 Points

Latest tweets