0 votes

I purchased the g.729 codec and placed at the top of the list however uLaw is the one that is used all the time.can u pls advise why this is? Ty. Kat

in iOS by (140 points)

1 Answer

0 votes


The codecs are used according to the negotiation from the server. If the server is setup to use G.711 with higher priority than G.729, then it will be used first. Please check with your provider for more details about the codec settings they use.

by (18.4k points)

Thnks Ivan foryour response. Ispoke with service provider as suggested  however they say g729 is the default codec used.any further ideas. Ty kat

If the codec to be used for the call is negotiated to be G.711, then the call will be fulfilled with that codec. However if you would like to generally use G.729, you may disable all of the other codecs and leave enabled only G.729. There is a risk though, that some calls may fail.

Or, you can ask your provider for the complete list of codecs they use and in what order, then to apply the settings in Zoiper and try them. They should be also able to give you more details on why the negotiated codec is different.

I received a further response from my service provider. 

When we forward incoming call to you, we offer PCMU, PCMA, G729 and GSM codecs(in that order), when you answer the call you offer PCMU, g729, GSM and PCMA codecs. The session runs using the first codec you offer, PCMU. Try to change codecs priority in zoiper settings, make g729 first.

So, even though I  have g729 as the first codec according to the service provider I am offering PCMU. Can u tell me how to fix this? Thanks. 

Ask your questions and receive answers from other members of the Zoiper Community.

Did you check our Help Section?

You are a Zoiper Biz or Premium customer? If so, click HERE to get premium support.
2,438 questions
1,541 answers
136,893 users