How to configure ZOIPER, using TLS, to accept a server certificate that has a CN different of a IP address?

0 votes

Hi.

I have configured my ZOIPER (version 3.3.25608, on Ubuntu 14.04) to use TLS. I also have configured the CA certificate to be used by ZOIPER. Everything is OK and ZOIPER can communicate with my SIP server (it is OpenSIPS 2.2) using TLS.

To get everything running well, I had to put the server IP address in the CN of my server certificate.

However, in production I can't use a static IP address for CNs. So, I have just changed it to a name. In this case, I got an error, as seem in ZOIPER log:

............................................................................................................

Certificate name mismatch: trying to connect to <192.168.21.40> remote cert domain(s) are <JFL_CA>

...........................................................................................................

To solve this error I guess that I have to configure something in Settings->Preferences->advanced->security.

How exactly to configure such security settings to avoid the name mismatch?

Any hint will be very helpful!

Best Regards.

asked Jul 30, 2015 in Linux by RodrigoPimenta (280 points)  
recategorized Oct 28, 2015 by Katina
share

1 Answer

0 votes

Just configure the same domain (used in CN of the certificate) in the Accouns->General->Domain  of Zoiper. That is the solution.

answered Jul 30, 2015 by RodrigoPimenta (280 points)  
share
How to upload certificate on Zoiper?
Welcome!
Ask your questions and receive answers from other members of the Zoiper Community.

Did you check our Help Section?

You are a Zoiper Biz or Premium customer? If so, click HERE to get premium support.
Top users 11/2019
  1. Tsetso.Zdravkov

    28080 Points

  2. Ivan

    18410 Points

  3. Joachim

    11490 Points

  4. Anton

    3950 Points

Latest tweets