0 votes

Hi! I am running zoiper on linux. And i'm trying to register on asterisk server via tls and have this problem: error 503 certificate is not trusted. How to add my selfsigned cert to trusted?

in Linux by (120 points)

1 Answer

0 votes

Hello,

You need to load the CA certificates in the first certificate option in the global TLS settings. The format is PEM. Zoiper supports multiple certificates to be dumped one after the other. It's a text file.

by (23.9k points)

does'nt work. i have used

but work when I enable Disable certificate verification - it works.

but when i restart the program, this setting become uncheked. why? how can i save this conf?

It is not possible to keep this option enabled after restart. This option is not persisted intentionally as disabling the setting and forgetting about it makes the communication vulnerable.
Using certificates without verifying them is pretty much useless. That is why the user must explicitly state on each startup that he would like the verification to be disabled.

Welcome!
Ask your questions and receive answers from other members of the Zoiper Community.

Did you check our Help Section?

You are a Zoiper Biz or Premium customer? If so, click HERE to get premium support.
2,438 questions
1,541 answers
2,314 comments
135,185 users