I cannot get LDAP working

+3 votes

Hi group

I am looking to move from Counterpath Bria to Zoiper but I really need the LDAP feature to work.

EVERY other softphone and hard phone has the following configuration:

LDAP Server – Server IP Address
LDAP CN or Username - cn=directory,ou=users,dc=IBCDirectory
LDAP Password - secret
LDAP Root or Base - ou=addressbook,dc=IBCDirectory

What is the Zoiper DC field? LDAP Base? If so then I cannot get it to work!

Regards

Mike

asked Jan 4, 2017 in Mac by michael.knill (150 points)  
share

1 Answer

0 votes

Hello Mike,

Hello everyone who need help about LDAP,


I had the same problem as you and here's how I solved it.

*** Note that my AD is Windows 2003

Zoiper support asked me to first update to the latest version of Zoiper Biz. I currently have Zoiper Biz 3.15.40036 64bit.

In this version, they added a checkbox "Use simple authentication". I'm not sure it helped me out but I turned it on.

*** Once in Settings-Preferences-Contacts, put a name you have in your LDAP into the search field. You'll then see it appear when the connexion will be done. Example: Joe

Now, here's what I put in the LDAP options fields:

- Use this server to search for contacts: checked

- Use simple authentication: checked

- LDAP server: [IP address of one of my AD server]

- Password: [The password of the user in CN field]

- CN: CN=John Doe,CN=Users,DC=[domain],DC=[local]

- DC: DC=[domain],DC=[local]

- Result limit: 20

- Min chars to search: 1

- Fields to search: sn, givenName (Only a few AD fields are available here)

- XMPP presence: <Do not use>


*** And here's the BIG THING!!! You have to wait a few seconds to let Zoiper do the connection!! You'll soon see the result of your search!

Hope it helps!


Martin

answered Apr 4, 2017 by mlemieux (160 points)  
share

I still face some problems.

1st - I can't update my Zoiper Biz. I try from application by "check for updates", but nothing happens. Then I logged in the panel on zoiper.com, but newest verstion I can download is 3.14! By that I just can't meet first requirement you sugested: Use this server to search for contacts: checked.

Then I try to configure everything like you guided:

- LDAP server: [IP address of one of my AD server]
Checked
Password: [The password of the user in CN field]
I typed in password for user with domain administrator permissions.
- CN: CN=John Doe,CN=Users,DC=[domain],DC=[local]
I typed CN: CN=domain.admin,CN=Users,CN=Admins,DC=domain,DC=local
(because my admin is inside Users/Admins inside tree)
and
CN=domain.admin,CN=Users,DC=domain,DC=local
also tried
CN=domain.admin,CN=Admins,CN=Users,DC=domain,DC=local

In followed rest of sugestions.
I don't know if I missing something, because Zoiper don't communicate with me by any way. We use Active Directory on Windows Server 2012. Also we used zoiper Biz 3.14.38765 32 bit till today.

I would appreciate for any sugestions and help.

Welcome!
Ask your questions and receive answers from other members of the Zoiper Community.

Did you check our Help Section?

You are a Zoiper Biz or Premium customer? If so, click HERE to get premium support.
Top users 06/2019
  1. Tsetso.Zdravkov

    25340 Points

  2. Ivan

    18370 Points

  3. Joachim

    11490 Points

  4. Anton

    3950 Points

Latest tweets