0 votes

Bluetooth device works with Freedompop Messaging, but when i place call with ZoiperBeta, bluetooth device beeps as if it will be used, but sound still goes through phone speaker not bluetooth.  Bluetooth appears available on ZoiperBeta in-call menus, but doesn't work.  ZoiperBeta 2.0.30, Galaxy S5 g900p.04, Lollipop 5.0

in Android by (120 points)

In such scenario do you have audio trough the device with other apps? What happens if you 1. Disconnect BT device 2. Try playing musing from some app and if there is audio ->3. Try to place a call?

yes, other apps, eg youtube, can play sound either through the phone speakers or through the bluetooth headset (Plantronics 8xx), and ZoiperBeta does succeed to activate the bluetooth headset thus producing the activation beeps in the headset earpiece, but ZoiperBeta voice sound still goes through the phone speaker, not the bluetooth headset

Can you try changing the "Audio Driver" in Zoiper->Config->Audio? Have you tested the headset with other VoIP applications? Zoiper just uses Android SCO API to know if device is available or not and route sound trough it, nothing special.

just updated FreedomPop messaging to its latest version, tried a call with bluetooth, phone audio didn't go thru bluetooth, rebooted, then FreedomPop messaging did put phone audio thru bluetooth, tried ZoiperBeta, phone audio didn't go thru bluetooth, changed audio driver from External Java Driver back to OpenSLES PortAudio Hostapi, tried again, rebooted, tried again. when i place a call i do hear activation beeps in the bluetooth headset but phone audio still goes thru the phone not the headset.

now using version 2.0.52, you've made good progress, bluetooth works, well at least sometimes!  it works more often than not for outgoing calls, yea!  strangely tho, if the callee doesn't answer and the call goes to voicemail, at that instant the call audio drops away from bluetooth back to the smartphone handset.  and similarly, if my call is interrupted with an incoming call, even if i ignore it and don't touch it, at that instant the call audio drops away from bluetooth back to the smartphone handset, and no pressing of menu buttons seems able to fetch it back.  so i just hung up the call and redialed, listened to the ringtone in my bluetooth headset, and this time the instant my brother answered once again the call audio dropped away from bluetooth back to the smartphone handset.  sheesh.  oh and incoming calls just won't go to bluetooth.  so, still a few bugs in the system.

Please log in or register to answer this question.

Ask your questions and receive answers from other members of the Zoiper Community.

Did you check our Help Section?

You are a Zoiper Biz or Premium customer? If so, click HERE to get premium support.
2,438 questions
1,541 answers
138,760 users