Is it possible to create a new Zoiper instance without administrator privileges?

0 votes

I am trying to start Zoiper through Zoiper API libraries with C# but I am getting the next error when I create a new instance of ZoiperAPI. 

************** Exception Text **************

System.Runtime.InteropServices.COMException (0x800702E4): Retrieving the COM class factory for component with CLSID {EDE266EE-2C85-4436-A9A3-940CC5B45A1F} failed due to the following error: 800702e4 La operación solicitada requiere elevación. (Exception from HRESULT: 0x800702E4).

   at System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean publicOnly, Boolean noCheck, Boolean& canBeCached, RuntimeMethodHandleInternal& ctor, Boolean& bNeedSecurityCheck)

   at System.RuntimeType.CreateInstanceSlow(Boolean publicOnly, Boolean skipCheckThis, Boolean fillCache, StackCrawlMark& stackMark)

   at System.RuntimeType.CreateInstanceDefaultCtor(Boolean publicOnly, Boolean skipCheckThis, Boolean fillCache, StackCrawlMark& stackMark)

   at System.Activator.CreateInstance(Type type, Boolean nonPublic)

   at System.Activator.CreateInstance(Type type)

   at Codere.DynamicsCSS.ProxyCSS.ControlPanel.InitializeZoiper()

   at Codere.DynamicsCSS.ProxyCSS.ControlPanel.<ControlPanel_Load>d__18.MoveNext()

--- End of stack trace from previous location where exception was thrown ---

   at System.Runtime.CompilerServices.AsyncMethodBuilderCore.<>c.<ThrowAsync>b__6_0(Object state)


Can anyone help me out???


asked Jul 4, 2017 in SDK & API by JaviO (160 points)  

Hello, only one instance of Zoiper can be running at a time.

I am not running several instances at a time. I am running one instance with standard user credentials and it seems that only admin users are allowed to instanciate Zoiper class. The error text asks me to elevate user privileges, which it's not possible. Any suggestions?

1 Answer

0 votes


This might help:

Open secpol[dot]msc to open the Local Security Policy and navigate to Local Policies --> Security Settings. 

You will see the setting User Account Control: Turn on Admin Approval Mode. Double-click on it and select Disabled.

answered Sep 10, 2017 by Zwagerman (3,870 points)  
Ask your questions and receive answers from other members of the Zoiper Community.

Did you check our Help Section?

You are a Zoiper Biz or Premium customer? If so, click HERE to get premium support.
Top users 02/2024
  1. Tsetso.Zdravkov

    34310 Points

  2. Ivan

    18410 Points

  3. Joachim

    11490 Points

  4. Anton

    3950 Points

Latest tweets