How come, as soon as I turn on VPN, Zoiper loses registration on my Samsung Note 5?

0 votes

 I am not using STUN, by the way. I find this frustrating, firstly because I cannot receive calls, and secondly, because I have to turn VPN off every time I want to make a call. The VPN service I am using is ExpressVPN. I would be very grateful if someone could offer a workable solution to this annoying problem. 

asked Aug 1, 2017 in Android by Mark Lerno (120 points)  
share

Zoiper is now working for me with ExpressVPN. I cannot remember exactly when it started working and neither do I know what was done by whom to make it work. Anyway, it's all good and I'm happy. 

2 Answers

0 votes

Some VPN services block SIP or the needed ports  by SIP. Additionally there might be some routing/ NAT issue. I can only suggest  that you contact your VPN service and ask them if they are not blocking  SIP.

answered Aug 1, 2017 by Tsetso.Zdravkov (22,820 points)  
share

ExpressVPN support could not help me but I found a solution. On someone's suggestion, I downloaded another VoIP client called CSipSimple. It works a treat with ExpressVPN. I have always liked Zoiper, bought the paid version and also paid for the G729 codec. Unfortunately, if Zoiper doesn't work via VPN, I cannot continue using it. 

Last year I went to Oman and I used a trial of Express VPN.  Zoiper did not work, CSipSimple worked perfectly well. 

I went back to Zoiper after I had difficulties with CSipSimple after a stay Belarus and I stopped using VPN for some time.

Last week, I installed Proton VPN and Zoiper continued to work fine.  This morning Zoiper stopped working with Proton VPN.  As I am regularly switching countries, I tried the VPN connection where Zoiper worked a few days ago, but without success.

Any thoughts?

I read some suggestions to ping the IP on VPN first, but how do I do this and how do I use the IP information for Zoiper?


0 votes

The order can matter. I found that I had to exit Zoiper completely, then start the VPN and pick up the IP, then start Zoiper again -- at which point the registration worked.

answered Apr 3 by eschulma (140 points)  
share
Welcome!
Ask your questions and receive answers from other members of the Zoiper Community.

Did you check our Help Section?

You are a Zoiper Biz or Premium customer? If so, click HERE to get premium support.
Top users 11/2018
  1. Tsetso.Zdravkov

    22820 Points

  2. Ivan

    18370 Points

  3. Joachim

    11480 Points

  4. Anton

    3950 Points

Latest tweets