No Click2Call after upgrading from Zoiper 3 to 5 (BIZ)

0 votes

Click2Call was working fine after installing Zoiper 5. Zoiper 3 was still on my Windows 7 system.

However, Click2Call was working via Zoiper 3 so I uninstalled it. Now I can't get Click2Call to work in any browser using either Zoiper 5 or after reinstalling Zoiper 3.

What happened?

In Firefox, I get this error message:

Firefox doesn’t know how to open this address, because one of the following protocols (zoiper) isn’t associated with any program or is not allowed in this context.

Seems the browsers don't know what to do with the protocol "zoiper://1234567890".

Using the latest Zoiper Click2Call v1.42 plugins for Chrome & Firefox. Both browsers are latest versions. This may explain why Zoiper 3 is no longer working as I had the older Click2Call add-on in Chrome when it did work.

Has anyone experienced this problem or something similar?



asked Nov 28, 2017 in Web (Safari, Chrome, IE, Firefox) by pstary (120 points)  
share

Hi,

You uninstalled the old plugin before installing the other one?

Open the Add-ons page using either:

  • Ctrl+Shift+a
  • orange Firefox button (or Tools menu) > Add-ons

In the left column, click Plugins.

Find the plugin change "Ask to Activate" to "Always Activate".

Your system information seems to list two different versions of a similarly named plugin.

Thanks for the reply. Here's what I did:

  • Had Zoiper Biz running on my Windows 7 64-bit PC. Working fine for close to 2 years.
  • Download and installed v5 Biz but did not uninstall v3. 
  • Deleted the old Chrome Click2Dial add-on first.
  • Then installed the latest v1.42 Click2Dial.
  • Noticed it worked but opened v3 to dial, not v5. That made sense since I did not uninstall v3.
  • So Uninstalled v3. No Click2Dial in v5.
  • Added Click2Dial v1.42 add-on for Firefox after updating the browser to latest v57. I generally don't use Firefox.
  • No Click2Dial in Firefox either and got the error message... "Firefox doesn’t know how to open this address, because one of the following protocols (zoiper) isn’t associated with any program or is not allowed in this context."
  • Looked at the registry and did not see any protocol registered for Zoiper5, only Zoiper.
  • Uninstalled v5 and rebooted
  • Reinstalled fresh v5. Still no Click2Dial.
  • Uninstalled v5 and reinstalled v3, still using v1.42 of the Click2Dial add-on. Click2Dial working with v3 on both Chrorne and Firefox.

Seems that v5 installer is not updating the registry with Zoiper5 protocols. But if this was an installer error, it would not work for anybody else either. I presume I am the only one with this problem?

Any suggestions?

Thanks.

This happenes because you had already installed Zoiper 3 and Windows have already associated the default URL handlers callto:, tel: and zoiper: to Zoiper 3. You need to manually associate them to Zoiper 5.

You can easily fix this by going to Start---> type "Default programs"---> select "Set your default programs", scroll down until you find Zoiper5, on the right click on "Set this program as default". After that you can check if it was properly associated by clicking on "Choose defaults for this program". Make sure that ZOIPER is marked, and if you need you may select CALLTO, SIP and TEL.

Click2Dial should be working now.

Thank you for the suggestion. Yes... I tried that but Zoiper 5 was NOT in the list of Default Programs... only Zoiper 3.

Since my original post, Zoiper has released v5.2.10 which fixes the problem of Zoiper 5 not showing up in Default Programs. After uninstalling the previous v5.2.6 and reinstalling v5.2.10, I was able to see Zoiper 5 in the Default Programs list and select it for the CALLTO, TEL and ZOIPER protocols.

 Now everything works great.

I think the way in installed Zoiper 5.2.6 over Zoiper 3 caused this issue. Anyone with this same problem should install this update.

Thank you again.

Hi,

You're welcome.

Suppose that was happening indeed.

Thanks for your feedback!

Merry christmas in a bit :-)

¿Como se cambian los protocolos CALLTO, TEL y ZOIPER en windows 10?


Translation according to google translate: "How are the CALLTO, TEL and ZOIPER protocols changed in windows 10?"

Edit: Please write your comments in English.

Please log in or register to answer this question.

Welcome!
Ask your questions and receive answers from other members of the Zoiper Community.

Did you check our Help Section?

You are a Zoiper Biz or Premium customer? If so, click HERE to get premium support.
Top users 05/2019
  1. Tsetso.Zdravkov

    24780 Points

  2. Ivan

    18370 Points

  3. Joachim

    11490 Points

  4. Anton

    3950 Points

Latest tweets