No sound on incoming call when iphone locked

0 votes

We are a systems reseller and wanted to offer an alternative to Bria so I'm testing Zoiper Premium.  Have found the app clean and responsive so far but have a very annoying issue where the iphone fails to make any sound or wake up the disp[lay when receiving a call while the iphone is locked.  Ive checked the IOS Notifications setting where 'Sound' is selected but makes no differance.  We know the phone is receiving a call as if you click the IOS home button duirng the incoming call to wake up the didplay there is a notification showing on the screen as Zoiper Premium - Incoming call from ...

I've tested with Bria and it does wake up and ring with sound.

Please can you assist asap as we have a rollout next week and would like to use this app.

Thanks in advance


Russ

asked Sep 19, 2015 in iOS by Tigerruss (120 points)  
share

This appeasr to be related to having an apple watch connected and IOS 9.  If you have the apopke watch notifications set to on for Zoiper then the watch alerts (doesnt ring) and the phone stays blank.  If I switch off the watch notifications then the phone wakes up on incoming call and shows notification of call but still doesnt make any sound.

I'm having this problem too.

1 Answer

0 votes

Hello,

 To be able to receive incoming calls while Zoiper is in background you need to use TCP transport type instead of UDP.
Start  your Zoiper for iOs, then go to Settings -> Accounts and open Network features
Note that your provider must support TCP otherwise your account will not register. Please refer to your provider for more assistance

In case it is not possible to use TCP:
Start  your Zoiper for iOs, then go to Settings -> Incoming calls and enable "Force background" and "Wi-Fi keepalive".


answered Sep 19, 2015 by Katina (23,910 points)  
share

I had already made sure that the Settings for Incoming calls had the "Force background" and "Wi-Fi keep alive" were enabled.

These settings allow the app to stay alive in the background and this IS working because the app does actually wake up on an incoming UDP packet and seems to even put a notification on the lock screen about the incoming call, its just that you are not aware of it because it fails to wake up the phone (screen stays black) and there is no sound.

So its working in the background, just need it to wake up lock screen and play raining sound as the other apps (Bria & Groundwire) do.

Look forward to more help

It sounds like your iOS privacy settings do not allow us to show the notification screen.

Please go to the ios settings, then look for the zoiper app settings or for the privacy settings or notification settings and set it to use notifications. (I don't have an iPhone with me to check where it is exactly).


All Privacy settings are already enabled

All Notifications settinsg are already enable

All Zoiper Application settings are already enabled.


BTW, This is on an IOS 9 software.  Didnt try on older IOS 8, maybe it's a new issue.  have you tested on IOS 9?

Hi, I have a similar problem here ... IOS9 and using TCP for transport. I see a message on the display, but - sometimes - there is no ringtone.

My problem might be linked to a bluetooth car adapter - when I disconnect it, the iPhone still wants to direct the ringtone sound to the bluetooth device (even if it's not available any more). I have to manually switch back to the iPhone loudspeaker (AirPlay settings).

Can the ringtone playback be forced to the loudspeaker somehow?

Greetings, Michael


Welcome!
Ask your questions and receive answers from other members of the Zoiper Community.

Did you check our Help Section?

You are a Zoiper Biz or Premium customer? If so, click HERE to get premium support.
Top users 12/2019
  1. Tsetso.Zdravkov

    28140 Points

  2. Ivan

    18410 Points

  3. Joachim

    11490 Points

  4. Anton

    3950 Points

Latest tweets