0 votes

In Russia all incoming rings have "+7" at the beginning of caller id. For example: +71234567890. In such format caller ids are stored in the call list, as well in phonebook. But if you try to ring with number in such format, zoiper dispays an error 603, because "+7" is not available for zoiper. You have to change manually "+7" to "8" for successful ring. It is perfectly inconvenient.

in Android by (120 points)

Hello. Have you tried using Number Rewriting?

You will need to configure Global Number Rewriting, so your Zoiper will know where you are located.
Please run your Zoiper for Android, then go to Config and select Number Rewriting.
Select your country from the list.
Now you need to go back, select Accounts and then select the account you will be using.
Scroll down to Number rewriting.
You can choose from a list of prefixes or add your own prefix.

I have tried many different combinations of "strip dial characters" and "rewrite international options" but effect is negative. It should be working if it was possible to choose none country with none prefix. In this case i should specify "+7" as "strip dial characters" and "8" as "rewrite international options". Unfortunately Zoiper doesn't allow to choose none country with option "number rewriting" is set in "Accounts".

But if I choose Russia as country, it automatically sets "7" as prefix, so "7" is added to number.

Zoiper assumes numbers for in-Russia calls with prefix "8" and this is a problem. For example, incoming number is +71234567890 where "+7" is prefix. I have to rewrite this number as 81234567890 and I don't see the way to do it yet.

Please log in or register to answer this question.

Ask your questions and receive answers from other members of the Zoiper Community.

Did you check our Help Section?

You are a Zoiper Biz or Premium customer? If so, click HERE to get premium support.
2,438 questions
1,541 answers
138,076 users