+1 vote


I’ve paid in Apple store and have active Push subscription but subscription is not recognized by Zoiper App despite multiple Synch Button attempts.

Could your please support?

in iOS by (150 points)

1 Answer

+1 vote


All our non-US users seem to be affected after 22nd of May.

We are currently investigating what is happening. At this point it seems that the Apple servers are sending Zoiper expired purchases. We are still trying to understand why this happens.

by (34.3k points)

Hi, I have the same problem. I have a Xeloq hosted PBX account and "Push notifications subscription" for almost a year now. This worked fine, but recently the push notification is not recognized anymore by my Zoiper App (version 3.26.2 for iPhone).

Please solve this quickly, because I am mostly unreachable for calls from outside now.


We understand your frustration and we are working hard to solve it. 

We have already pushed a new update which is waiting for Apple's approval in the AppStore.

What's the status of the update? When will the PUSH notifications for non-US iOS users work?

Same problem here... This is very annoying since basically I cannot be reached nore phone...

Any update would be appreciated

Any news! I have the same problem . I am based in Montreal canada and using voicemeup voip services. We can't get push notification to work. We are using the latest version of Zoiper 3.30.1

I have the same problem. If you know there is a problem why do you continue to sell this service?

The issue should have been solved by now. 

my connection to voip.ms was pretty good last week; however it drops often, even when I have subscribed to the push notifications. Today dropped twice and it is just mid morning here in toronto, canada.

The only way to get it back working on my iphone 6 is to go to settings (in zoiper); incoming calls; uncheck "use push notifications", and then recheck the same.

I then get the nice green "ready" notification when I got to the zoiper dialpad.

Bom dia, estou com a versão 3.30.1 e não consigo registrar a minha conta. a mensagem que recebo é a seguinte:

Bad request - missing push device token (400)

Adquiri a versão paga, para utilizar o push, e agora não consigo nem utilizar o aplicativo.

pode me auxiliar?

Ask your questions and receive answers from other members of the Zoiper Community.

Did you check our Help Section?

You are a Zoiper Biz or Premium customer? If so, click HERE to get premium support.
2,438 questions
1,541 answers
138,760 users