0 votes

Since I did the free upgrade to 10, I cant answer a call from the Plantronics Savi 740 headset. I get the ringing in the ear but, cant answer, sounds great when I go to the answer on Zoiper. I got the Zoiper Pro because it worked fine . Now.. Trouble and I have been on chat with Plantronics with now success.. Anybody know what my problem is???  Thanks

in Windows by (120 points)

1 Answer

0 votes


There are no known compatibility issues with Zoiper on Windows 10.

Please check if you have Skype for Business (MS Lync) or any other software that might intercept the HID activity. If you do, make sure that they are not running.

Also make sure that "Use generic Headsets" is enabled. To do so, open Zoiper -> go to Settings -> Preferences -> Audio tab -> Device sub-tab

by (34.3k points)
Ask your questions and receive answers from other members of the Zoiper Community.

Did you check our Help Section?

You are a Zoiper Biz or Premium customer? If so, click HERE to get premium support.
2,438 questions
1,541 answers
138,094 users