Iphone client no audio

0 votes

Hi,

I can make and receive calls to and from my Iphone client (IOS9.1), however, when I make a call from the client no audio can be heard either way, but when I make a call to the client audio can be heard.


I've done a SIP trace and analysed it in Wireshark and audio is sent.


Also in the 'Stats' on the client during a call, the packets received stays at zero but the sent packets ticks over.


I've tried this over both Wifi and 3G/4G in case it was a NAT/ routing issue (my provider doesn't block SIP traffic).


Why do I only hear audio when making calls to the Iphoe client and not from it???


Any help would be great.


Cheers,


Carl   

asked Nov 3, 2015 in iOS by Carl Lowe (130 points)  
share

Did you get any answer to this? having the same issue!! 

1 Answer

–1 vote

 Please make sure that  Zoiper is allowed to use the microphone on your device.
Open iPhone's "Settings"->"Privacy".

If the microphone is enabled, but still there is one-way audio, or no audio at all, please try to disable or enable STUN according to its current state. "STUN" is located in Zoiper -> "Settings"->"Accounts"->your account->"Network Settings".

If using Zoiper with WiFi, please make sure that the routing device is not blocking ports used by Zoiper. The default ports used by Zoiper are:

SIP port is 5060
IAX port is 4569 UDP
RTP port is 8000 and above UDP

Default STUN vallues:
Server hostname /IP :stun.zoiper.com
Port : 3478 UDP/TCP
Refresh period : 30

answered Nov 3, 2015 by Katina (23,910 points)  
share

Hi,


None of these fixes work, I've tried them.


I have this issue both over Wifi and over 3G/4G and as mentioned, my provider doesn't block SIP traffic. If it was routing related, I'd expect 3G/4G to work, but it does not.


Also, I get audio when making and receiving calls when using the PC client, which goes through the same networking equipment. It seems to be an issue with the Iphone client?

Cheers,


Carl

It is not an issue with the iphone client. Zoiper cannot play the incoming audio if it doesn't receive it. The server is not sending them to the right place.


The settings for rport and stun can help the server decide on where to send the audio to, in this case it doesn't seem to help. The provider or system administrator will need to check what is going on at the server side.

You are correct that this is most likely a NAT issue. (most 3g/4g networks are also behind nat).

Hi Joachim,

Thanks for your reply.

I've ran a trace and analysed it in Wireshark.

Zoiper initiates the call, telling us to send rtp traffic to 127.0.0.1 (not really allowed!). What we do in these situations is wait for rtp to be sent to us, and we then correct where we send the rtp to (we cannot send to 127.0.0.1).

 

We send 183 trying with correct sdp telling zoiper where to send traffic.

We send 200 ok with correct sdp telling zoiper where to send traffic.

Zoiper acks our OK.

 

No rtp traffic from Zoiper and no correct sdp from zoiper - so we have no information from zoiper where to send the traffic.


Do you have somewhere I can send you our trace, if it'd help?


Regards,


Carl

The phone should not send 127.0.0.1, can you please contact us on support@zoiper.com so that they can investigate this further.

Since this happens with both wifi and 3g, it is unlikely to be SIP ALG on the router.

(mention this post in the email please).


Hi Joachim,


I've sent an email to support but apparently it's for premium users, not free users. 

Whether I'll get a response/fix regarding this issues remains to be seen.

Thanks for helping.


Regards,


Carl

I have sent you an email via our system.

Welcome!
Ask your questions and receive answers from other members of the Zoiper Community.

Did you check our Help Section?

You are a Zoiper Biz or Premium customer? If so, click HERE to get premium support.
Top users 10/2020
  1. Tsetso.Zdravkov

    33510 Points

  2. Ivan

    18410 Points

  3. Joachim

    11490 Points

  4. Anton

    3950 Points

Latest tweets