Why does Zoiper keep turning off on android samsung galaxy s5?

0 votes

Zoiper keeps turning itself off when I need it on all of the time. 

I keep missing important calls and getting voice-mails instead but I need to answer the calls.

I use kaspersky internet security could it be this as I can't see anything in the settings? Or maybe it's an android setting?

There is a new "app optimization" feature on android that I don't understand. I think I disabled it for andrioid though.

Or maybe it's just a problem on Zoiper?

Please help, Rob

asked Jan 20, 2016 in Android by Robert Orrell (120 points)  
share

What do you mean by "zoiper keeps turning itself off"? What is your device brand and Android version?

well, I tried to explain it a little more in the text above not just in the subject line. 

I mean one minute it works and is showing as ready in the notification drop down area and the next minute it has switched off!??

Android version 5.0.2 Samsung galaxy s5

1 Answer

0 votes

There are several things to check:

- what error message is displayed for the registration failure? You can check that by opening Zoiper and going to "Config"-"Accounts" - message will be below your account name.

- your mobile data provider might be filtering SIP and its ports, even tough you might be unaware of that.

- check Zoiper "Config"-"Connectivity" and make sure "Run in background" and "Keep Alive WiFi" are enabled. "Stay Awake" option is better to be used with TCP transport, so it is up to you. "Keep Alive WiFi" option cannot overwrite your WiFi Settings(Android Settings).

- check if background data is not restricted for Zoiper. 

- check Kaspersky settings to make sure it is not blocking Zoiper and connections it initiates.

- try TCP transport, if supported by your provider. Maybe even alter STUN and rport, although it seems they wont affect the described behavior.

answered Jan 21, 2016 by Anton (3,950 points)  
share

I'm not getting any error as it just stops working and I have to restart the app when i eventually notice that it has switched itself off. As soon as i switch it back on the account registers again and starts working.

I have changed the transport type from UDP to TCP and will see what this does. I'm not really sure what to do with STUN and rport so I haven't changed anything 

How do i check background data isn't restricted? There doesn't seem to be anything blocking it in kaspersky

"restrict background data" is an Android setting and it is per-application http://www.samsung.com/ca/support/skp/faq/1074613 . It shouldn't be enabled if you didn't did it manually.

Welcome!
Ask your questions and receive answers from other members of the Zoiper Community.

Did you check our Help Section?

You are a Zoiper Biz or Premium customer? If so, click HERE to get premium support.
Top users 04/2020
  1. Tsetso.Zdravkov

    31380 Points

  2. Ivan

    18410 Points

  3. Joachim

    11490 Points

  4. Anton

    3950 Points

Latest tweets