Zoiper in IOS has connectivity problems in background mode.

0 votes

Zoiper does nor work properly receiving calls in background mode in IOS

asked Dec 7, 2016 in iOS by dlozano (120 points)  
share

1 Answer

0 votes

Can you be more specific about the issues you observe?

answered Dec 9, 2016 by Ivan (18,370 points)  
share

Zoiper in IOS lost register in background mode, therefore incoming calls fail, I have tried using TCP to keep the socket open but the register is even lost.

Make sure you do not use keep alive on the server or zoiper could get killed. Other than that it should work reliably. It could fail for maximum 10 minutes if there was no network for a while.


In such case, zoiper would lose the TCP connection, have limited time to try to reconnect before being forced to sleep by ios and since there is no active TCP socket, not be notified about a new network change.


Hello, keep Alive in my server is not enabled, and I have seen that the zoiper lost register even with network on all the time.

Please also check the registration expiry on the server, it should be a minimum of a minimum of 10 minutes. If that doesn't work, please send us an email on support@zoiper.com with the exact model of phone, version of ios and if you connect on wifi or 3g/4g so that we can test the scenario in the lab.

Welcome!
Ask your questions and receive answers from other members of the Zoiper Community.

Did you check our Help Section?

You are a Zoiper Biz or Premium customer? If so, click HERE to get premium support.
Top users 03/2019
  1. Tsetso.Zdravkov

    24300 Points

  2. Ivan

    18370 Points

  3. Joachim

    11490 Points

  4. Anton

    3950 Points

Latest tweets