No video on Softphone

0 votes

I have zoioper installed on a windows laptop and android phone.  I have ensured they are both running the same codecs.  Call setup and audio work great, just no video.  The screens are black on both outgoing and incoming video.  Sometimes, if I press hold and open the call back up, I can see myself on the outgoing screen but nothing is received on the other end.  I have tried this with both endpoints on the same network and across the firewall with the same result.  Both are registered to a grandstream pbx with video enabled.  The grandstream hard phones work fine with video to each other.  I cannot get 2 zoiper clients to use video.

Any suggestions?

Thanks in advance.

asked Aug 23, 2015 in Windows by kkennemore (120 points)  
recategorized Oct 28, 2015 by Katina
share

1 Answer

0 votes

I believe we have investigated this in the past and the issue was related with an incomplete implementation of the SDP on the grandstream PBX, they did not support dynamic codecs in the SDP back then, i don't know if they have made any fixes for this since,

We would need a packetcapture to investigate this further. 

answered Aug 25, 2015 by Joachim (11,490 points)  
share

No problem.  What point of view would you like the capture from?  PBX, callee or caller?

It would be best to have the pcap from a pc running zoiper. You can email it to support@zoiper.com

Something else to watch out of, be sure to use TCP, not UDP when making video calls. When video is enabled, the invite packets get quite large and the UDP packets could arrive truncated, the video negotiation is done at the end of the packet and might be missing.



Welcome!
Ask your questions and receive answers from other members of the Zoiper Community.

Did you check our Help Section?

You are a Zoiper Biz or Premium customer? If so, click HERE to get premium support.
Top users 11/2019
  1. Tsetso.Zdravkov

    27580 Points

  2. Ivan

    18410 Points

  3. Joachim

    11490 Points

  4. Anton

    3950 Points

Latest tweets