Why won't Zoiper follow Android's DND (Do Not Disturb) settings?

0 votes


It seems Zoiper will not adhere to my Do Not Disturb (Silent hours) settings. It rings in the middle of the night while everything else remains quiet.

I'm using a OnePlus 6, on Android 8.1.0.

Thank you

asked Sep 18, 2018 in Android by bohemier (120 points)  

I'm having the same problem on Android 9 with a pixel 2 XL. It does not respect the Android do not disturb settings. I did notice when it installed it asked for permission to change do not disturb settings. I wonder if that is part of the problem?  Zoiper 2.7.8 from the play store.


Currently there is indeed issue with the DND settings on some phones, they will be resolved with our next update.

1 Answer

0 votes


We have tested Zoiper against the pure android in all Google phones and some other brands, it should follow the system DND settings, unless there is some customisation by the manufacturer which behaves differently. 

answered Sep 18, 2018 by Tsetso.Zdravkov (24,260 points)  

Thanks for your answer... I seem to have DND working right now. Best regards,


Ask your questions and receive answers from other members of the Zoiper Community.

Did you check our Help Section?

You are a Zoiper Biz or Premium customer? If so, click HERE to get premium support.
Top users 02/2019
  1. Tsetso.Zdravkov

    24260 Points

  2. Ivan

    18370 Points

  3. Joachim

    11490 Points

  4. Anton

    3950 Points

Latest tweets