0 votes


It seems Zoiper will not adhere to my Do Not Disturb (Silent hours) settings. It rings in the middle of the night while everything else remains quiet.

I'm using a OnePlus 6, on Android 8.1.0.

Thank you

in Android by (120 points)

I'm having the same problem on Android 9 with a pixel 2 XL. It does not respect the Android do not disturb settings. I did notice when it installed it asked for permission to change do not disturb settings. I wonder if that is part of the problem?  Zoiper 2.7.8 from the play store.


Currently there is indeed issue with the DND settings on some phones, they will be resolved with our next update.

For me, although the Alarms-Only do-not-disturb mode works as expected, Priority-Only does not-- this supposed to let through only calls in my contacts list (or, optionally, only the "starred" contacts), and does so for native cellular calls, but all incoming Zoiper calls ring through when DnD is set to Priority, regardless of the calling number.

This is under Android 7.0 on a Motorola Moto G5+ XT1687, running Zoiper 2.7.12, Library revision 2.9.2.  In case it matters, I'm connecting via IAX protocol to an Asterisk server under my control.

1 Answer

0 votes


We have tested Zoiper against the pure android in all Google phones and some other brands, it should follow the system DND settings, unless there is some customisation by the manufacturer which behaves differently. 

by (34.3k points)

Thanks for your answer... I seem to have DND working right now. Best regards,


Ask your questions and receive answers from other members of the Zoiper Community.

Did you check our Help Section?

You are a Zoiper Biz or Premium customer? If so, click HERE to get premium support.
2,438 questions
1,541 answers
138,760 users