+1 vote

I have Zoiper running on my PC no problem at all. Gets calls, makes calls, shows up on my dashboard as being connected. I'd like to get my mobile working as well for times I'm not at my PC, but I cannot get it to connect. It will connect if I'm not on wifi (with problems - another story another day) but I cannot get it to connect via the wifi. I'm not entirely sure what to do to get it going. Does anyone have any ideas? I have tried port forwarding with no joy.

in Android by (130 points)


Do you see any error message when you try to connect on Wi-Fi ? You can find the exact error under your account name in the settings menu, written in red.

If you see SIP 408, try some of the suggestions here: https://www.zoiper.com/en/support/home/article/19/Error_408_Request_Timeout#android

Thanks. That was exactly the problem and had tried those steps but no joy at all sadly.


I have this same issue. Mac Zoiper works fine, Android does not. I'm 99% sure this because of ALG on my broadband router, unfortunately I am not able to switch ALG off (Vodafone Broadband UK). This took me a while to figure out because the Mac Zoiper was working, same as the OP. I did some analysis and found that the two Zoiper versions behave differently: the Mac version writes the public IP address into the Via part of the SIP packet and the Android version writes the private IP address in. So the (non) helpful ALG function doesn't change anything on the initial reg packet from the mac version, but changes it for the Android version.

I'm not a SIP expert, but I don't think this is a Zoiper problem, as the built-in SIP client in Android behaves the same way, however it is interesting that the two versions behave differently. 

To the OP - if you have an option to disable ALG for SIP on your router, give this a try. If you don't have that option you may be out of luck or need to replace your router.

To Zoiper - it would be a nice-to-have feature to be able to manipulate this behaviour in the settings to hack around this kind of thing. 


You can workaround the SIP ALG by using TLS + SRTP. In this case the ALG will be unable to see the packets or rewrite them. If lacking the public address leads to issues, then probably the PBX is not NAT aware, thus you can try enabling the STUN option. 

Please log in or register to answer this question.

Ask your questions and receive answers from other members of the Zoiper Community.

Did you check our Help Section?

You are a Zoiper Biz or Premium customer? If so, click HERE to get premium support.
2,438 questions
1,541 answers
138,760 users