Presence on XML directory

0 votes

Hi Zoiper support,

We provide to our customer a XML file with all the internal contact from their internal directory .

We would like to enable the presence on that directory, but after several try it still doesn't works .

we provide this config file fo the directory part :

    <contact_services>

        <contact_service>

            <ident>platform</ident>

            <name>Platform Contact Service</name>

            <type>xml</type>

            <enabled>true</enabled>

            <account_mapping_type>custom</account_mapping_type>

            <account_id>platform1</account_id>

            <presence_account_mapping_type>custom</presence_account_mapping_type>

            <presence_account_id>platform1</presence_account_id>

            <hide_contacts_without_name>false</hide_contacts_without_name>

            <hide_contacts_without_phone>false</hide_contacts_without_phone>

            <uri>https://*********/directory/*****/contacts.xml</uri>

        </contact_service>

    </contact_services>


like that if i check in the UI settings => contacts => XML,

the use this account for the presence is still grey , but my account for dialing is correctly switch

I thought it was because it already enable on the Native contact center but even if I disable it, I can't still provide the XML account presence .

Is it a normal behavior ? I miss something ? Any clue ?

Thanks in advance for your help,

asked Feb 5, 2019 in Windows by allocloud (120 points)  
share

Hello,

The presence for the XML service has just been added with Zoiper 5.2.25(latest version), with the older releases it used to work only for the native contacts. 

Hi,


Thanks for your answer but it doesn't seems to works with provisioning :


xml config file :

    <contact_services>

        <contact_service>

            <ident>platform</ident>

            <name>Platform Contact Service</name>

            <type>xml</type>

            <enabled>true</enabled>

            <account_mapping_type>default</account_mapping_type>

            <account_id></account_id>

            <presence_account_mapping_type>custom</presence_account_mapping_type>

            <presence_account_id>platform1</presence_account_id>

            <hide_contacts_without_name>false</hide_contacts_without_name>

            <hide_contacts_without_phone>false</hide_contacts_without_phone>

            <uri>https://*/zoiper/*/contacts.xml</uri>

            <username></username>

            <password></password>

            <authentication_type>none</authentication_type>

        </contact_service>

    </contact_services>



Contact.xml

        <Contact id="900123">

            <Name>

                <Display>Nicolas Turcksin</Display>

                <First>Nicolas</First>

                <Last>Turcksin</Last>

            </Name>

            <Info>

                <Company/>

            </Info>

            <Phone>

                <Type>Work</Type>

                <Type>Phone</Type>

                <Phone>200</Phone>

            </Phone>

            <Phone>

                <Type>Home</Type>

                <Type>Cell</Type>

                <Phone/>

            </Phone>

            <PresenceMappingType>Service</PresenceMappingType>

            <Avatar>

                <URL/>

                <MIME/>

                <Data/>

            </Avatar>

        </Contact>



When I check on the UI in Zoiper, under settings -> contacts -> xml , the value of use this account for presence stay on Do not use, 

When I check the advanced settings of my contact, the presence account is still on do not use .

Can you help me ? 

rgds,

I forgot to mention, by default the presence will be enabled only for the "IPphone" field. This should offload the server by preventing Zoiper from trying to subscribe for thousands of numbers, which may lead to flood protection kicking in on some servers.

Thanks works as expected .

Sorry to reply to an old thread but for some reason my posts are not being approved.


I've been trying for days to get Zoiper mobile presence working. I have presence working with the Bria 5 mobile app (it will show Available, In Call, Number the person is calling etc., it uses SIP SIMPLE as well) however with Zoiper mobile it will only show if the phone as "available" if its registered or "offline" if it's unregistered, it will not show if any other phones are on calls etc. When I run a packet capture on my Freeswitch server I see the subscribe and notify messages on Freeswitch are almost exactly the same and Zoiper is getting notified but the presence isn't updating, has anybody run into a similar issue?

Please log in or register to answer this question.

Welcome!
Ask your questions and receive answers from other members of the Zoiper Community.

Did you check our Help Section?

You are a Zoiper Biz or Premium customer? If so, click HERE to get premium support.
Top users 06/2020
  1. Tsetso.Zdravkov

    32670 Points

  2. Ivan

    18410 Points

  3. Joachim

    11490 Points

  4. Anton

    3950 Points

Latest tweets