How to correctly install zoiper free 64 version on Jessie debian ?

0 votes

Hi,

I installed zoiper 3.3 linux free 64 version on Debia Jessie with xfce4.10

The application doesn't run correctly: impossible to create an account, freeze when Preferences is stroken.

/var/log/messages contains:

debian /etc/gdm3/Xsession[4012]: /usr/bin/zoiper: error while loading shared libraries: libXinerama.so.1: cannot open shared object file: No such file or directory

The command ldd zoiper gives:

...
libXinerama.so.1 => /usr/lib/x86_64-linux-gnu/libXinerama.so.1 (0x00007fbb84791000)
...

any explanation ?

asked Oct 9, 2015 in Linux by bertaudmarc (150 points)  
share

1 Answer

0 votes
Best answer

Hello,

Zoiper 3 also needs Pulseaudio. Please make sure you have pulseaudio installed on your system,.


answered Oct 9, 2015 by Katina (23,910 points)  
selected Oct 14, 2015 by bertaudmarc
share

you are right ! thks


how did you find this solution ? it's not evident

Zoiper3 uses Pulseaudio, as it is newer, and Zoiper Classic is using Alsa as it was widely used back in the day. 

I hear sound by testing in the audio wizard but when I call an "hello world" account, I hear nothing.

Any ideas ?

Does the other side hear you?

I installed AsteriskNow on a virtual machine (KVM/qemu) and I am just testing their "hello world" example. I am at the beginning of my knowledge in this domain. The example proposes to use the softphone Zoiper.

I "see" in the Asterisk CLI the messages between Asterisk and Zoiper but I don't hear the "hello world" message.

Sorry, I cannot say more but ready to check what you want ;-)

Note:

With wireshark, I see a message between asterisk and zoiper: request bye sip 6001@<ip>:<port> and just after 489 bad event, 401 unauthorize. <ip> is not a local ip but my internet address !?
Asterisk also sends many RTP messages.

Note:
Zoiper confirms the establishment of the connexion and the hangup.

If using a SIP account, disabling STUN (or enabling it, depending on its current state) could help.

Please open settings -> Preferences;
click on Accounts;
select your account from the list on the left;
click on Advanced;
enable or disable STUN;
save the changes and try to recreate the issue.

I disabled STUN in the Advanced preferences and ... that's work !

I suppose that is work because I tested between two internal machines ?

If the client and the server are in the same network you would not need to have stun enabled.

Thank you very much for your help !

Welcome!
Ask your questions and receive answers from other members of the Zoiper Community.

Did you check our Help Section?

You are a Zoiper Biz or Premium customer? If so, click HERE to get premium support.
Top users 04/2020
  1. Tsetso.Zdravkov

    31380 Points

  2. Ivan

    18410 Points

  3. Joachim

    11490 Points

  4. Anton

    3950 Points

Latest tweets