Zoiper not working with Logitech G430 headset

0 votes

I purchased a Logitech G430 Headset. I'm currently trying out Zoiper 3.9.3 on Windows 8.1.

I have my headset set in Windows as Default Device, and Default Communication Device. Also, under preferences/audio/device I have my headset set up correctly.

When I go to the Audio Wizard, I do a speaker test on the currently selected device and no sound comes out. I also test the microphone, and the input bar doesn't move.

Interestingly enough, If I disconnect the usb sound card that comes with the G430, and plug straight into the computer audio ports, it works fine, but I lose the configuration settings that come with the USB sound card. Which is not an option. I just need Zoiper to work with the complete setup.

All audio drivers are installed correctly. I'm also testing 3CXPhone and Counterpath X-Lite to see which one I'll purchase, and none of these have the problem that Zoiper is experiencing.

What can be wrong and how can I fix it?

asked Oct 22, 2015 in Windows by achild (120 points)  
share

1 Answer

0 votes

Please check if your Logitech headset comes with any software that might control it e.g. 'Logitech gaming software'. If you have any, please try removing it. It seems that there is a firmware update for the Logitech G430 headset with some fixes. Make sure you have it installed.

answered Oct 22, 2015 by Katina (23,910 points)  
share
I have a G930
Welcome!
Ask your questions and receive answers from other members of the Zoiper Community.

Did you check our Help Section?

You are a Zoiper Biz or Premium customer? If so, click HERE to get premium support.
Top users 07/2020
  1. Tsetso.Zdravkov

    32790 Points

  2. Ivan

    18410 Points

  3. Joachim

    11490 Points

  4. Anton

    3950 Points

Latest tweets