can Zoiper in IOS work in background and not be shown in the background screen? Clocks was better.

0 votes

When you set zoiper to recieve incoming calls in background it appears in the background screen instead of wallpaper image (clock by default). It's noising as there is no any useful information. Can it work without showing on the screen?

asked Aug 2, 2015 in iOS by Sergey Moskovskikh (120 points)  
share

I have the same issue. Zoiper will ring when open, but when running in background with "Force background" and "Wi-Fi Keep Alive" both on, and set to TCP, calls are not received. Please make suggestion or try to resolve this bug?

1 Answer

0 votes

Please switch to TCP instead of UDP if you can. It will use a lot less battery and will be much more reliable. 

The running in background with UDP is not officially supported by Apple and is a bit of a dirty hack for servers without UDP support.

When using TCP, Zoiper will hibernate and iOS will take over the TCP connection, will reply to TCP keep alives and will not wake up the application unless a SIP message is sent to zoiper.

Each 10 minutes Zoiper will wake up, update the registration to the server and will go back to sleep. 

Additional benefit when using TCP:
If the application crashes or gets killed by iOS or the phone is rebooted, Zoiper will automatically restart when using TCP.

Warning:
If the Application is woken up too many times because of incoming SIP packets, iOS might decide to kill the application to preserve battery. To avoid this, please avoid using SIP keep alive packets (qualify on asterisk) or at least dont send them too often.

If you cannot use TCP, for now it is not possible to "hide" the app completely while in background, but it is technically possible and i will discuss it with the development team to add this for a future release.




answered Aug 3, 2015 by Joachim (11,490 points)  
share
how i can get incominig call in background?
I changed to the TCP but it still doesn't sounds

I have the same issue. Zoiper will ring when open, but when running in background with "Force background" and "Wi-Fi Keep Alive" both on, and set to TCP, calls are not received. Please make suggestion or try to resolve this bug?

If you are already using TCP, make sure there is no keep alive or presence configured  on the server that will cause too much activity on the socket or ios will kill the application.

Keep in mind that there might be periods of up to 10 minutes without incoming calls. This will happen if there was no network for more than 30 seconds.

Other than that it should work fine.

Thanks Joachim!!  What actually happens, is the phone does not ring aloud, however, after ringing over to voicemail the phone makes a faint static, pulsing sound?!?! This continues until I manually shut down the Zoiper app. Strange, I know!!!

I have double-checked all settings and reinstalled to Zoiper app on my iPhone 6, and no resolution. This seems very strange????

Any new concepts based on this additional detail would be great!!!

G. 

Hello,

Try to use TCP transport and disable the options in the Incoming calls section of Zoiper's Settings menu. This should stop the producing of the faint sound. Also a restart of the application might be also needed.

Welcome!
Ask your questions and receive answers from other members of the Zoiper Community.

Did you check our Help Section?

You are a Zoiper Biz or Premium customer? If so, click HERE to get premium support.
Top users 06/2019
  1. Tsetso.Zdravkov

    25380 Points

  2. Ivan

    18370 Points

  3. Joachim

    11490 Points

  4. Anton

    3950 Points

Latest tweets