Zoiper on iOS - Keeps Unregistering despite me buying the Push Notification

0 votes

Some details here.

iOS Version: 11.3.1     (iPhone 6)

Using Zoiper for phone calls over the VOIP.ms service. Paid for Push Notifications (proxy protocols on SIP, and Push Transport on TCP). Force Background and Wi-Fi Keep Alive are both enabled. 


My issue is that if I turn Zoiper on for the first time, it usually says "Not Ready" in red, then rapidly turns green and says 'ready' as it successfully registers. If I try to use it then, perfect. 

 

But it seems to keep de-registering. I tried to give a call onto Zoiper after 2 hours to ensure it still worked - but Zoiper never ran. I turned it on in my iPhone - and it first said "not ready" in red first before successfully re-registering. 


Is there any solution to this? I bought Push Notifications because I thought this would help - but it hasn't. I made sure that the account registered with Zoiper was using TCP for Transport (under Accounts, Network Settings) - that didn't seem to work.


Is there any trick whatsoever to making sure that Zoiper stays registered? I'm at a loss as to what the point of the service is if I can't be SURE that I will get my incoming calls.


Zain

asked Feb 5, 2019 in iOS by NewZoiperUser (120 points)  
share

Hello,

After you have purchased the PUSH service, have you enabled it from the "Incoming calls" menu ? 

Have you also tried enabling TCP +RTP for PUSH protocols and settings the PUSH transport to TLS ?


I see exactly the same behaviour. Paid for the push notifications and enabled them in Incoming Calls. Using TCP for transport. Sometimes zoiper stays registered for hours without problem, sometimes it behaves as described above - when opening Zoiper, it first shows for a moment "Not registered" and jumps fast to "Registered".

But very often it unregisters with the operator minutes after registering - as happened just now: at 10:07 SIP registration succeeded, registration valid until 12:07. But five minutes later the SIP operators reports no registration. And there was no change of network in the meantime, all the time continuously connected to a stable WiFi.

So the behaviour of the push notification is very unpredictable and especially not stable, which should not be a case for a paid service...

Hi,

Do you have your sip account registered on another device at the same time ?


2 Answers

0 votes

I did not have. Since today noon I have, because I need a stable connection and thus use other client. With SessionTalk I do not experience the problems described...

answered Apr 20 by TomKov (200 points)  
share
0 votes

...btw. why would it be a problem? My SIP provider supports multiple registration of the same account, I tested it with multiple hardare SIP phones and it worked.

With this account I am mentioning above I was registered only on one device, though.

answered Apr 20 by TomKov (200 points)  
share
Welcome!
Ask your questions and receive answers from other members of the Zoiper Community.

Did you check our Help Section?

You are a Zoiper Biz or Premium customer? If so, click HERE to get premium support.
Top users 05/2020
  1. Tsetso.Zdravkov

    31850 Points

  2. Ivan

    18410 Points

  3. Joachim

    11490 Points

  4. Anton

    3950 Points

Latest tweets